tzkr.net
当前位置:首页 >> 易语言怎么用按钮切换图片框的图片 >>

易语言怎么用按钮切换图片框的图片

很遗憾的告诉你,这是不行的。除非你手动把各个图片资源放到一个数组,然后才可以循环提龋比如: .版本 2 .支持库 spec .子程序 _按钮2_被单击 .局部变量 图片数组, 字节集 .局部变量 i, 整数型 ' ----手动加入图片 加入成员 (图片数组, #图片1)...

.版本 2 .程序集 窗口程序集2 .子程序 _按钮1_被单击 载入 (窗口1, , 假) .子程序 _按钮2_被单击 窗口1.图片框1.图片 = #图片2

你好,按钮形状是无法改变的,除非你用图形按钮,易语言自带的组件都不是很美观,需要用到第三方模块,比如彗星真彩控件模块,可以实现PNG按钮,也就达到你要改变形状的目的

.版本 2.子程序 _按钮1_被单击.局部变量 索引, 整数型, 静态索引 = 索引 + 1图片框1.图片 = 多项选择 (索引, #图片1, #图片2, #图片3).如果真 (索引 = 3) 索引 = 0.如果真结束

.版本 2 .子程序 _按钮1_被单击 .局部变量 number, 整数型, 静态 number = number + 1 .如果真 (number = 20) number = 0 .如果真结束 .如果真 (number = 1) 图片框1.图片 = #图片1 .如果真结束 .如果真 (number = 2) 图片框1.图片 = #...

1.添加一个图片框组件 2.添加一个按钮组件 3.添加一个通用对话框组件 以下为源码: ------------------------------------------------------- .版本 2 .程序集 窗口程序集1 .子程序 __启动窗口_创建完毕 .子程序 _按钮1_被单击 通用对话框1.过...

经试验,是可行的,只是你代码写错了。你把图片框1写成图片框15了。 这是我的代码: .版本 2 .子程序 _图片框1_鼠标左键被按下, 逻辑型 .参数 横向位置, 整数型 .参数 纵向位置, 整数型 .参数 功能键状态, 整数型 .如果真 (通用对话框1.打开 ())...

.版本 2 .如果真 (通用对话框1.打开 ()) 照片 = 读入文件 (通用对话框1.文件名) 图片框.图片 = 读入文件 (通用对话框1.文件名) .如果真结束 你试试这个代码就知道了: .版本 2 .子程序 _按钮1_被单击 通用对话框1.过滤器 = “文本文件(*.txt)|...

简单:代码如下 你需要定义图片框控件数组, 按钮事件: A=取随机数(图片框个数最小值,图片框个数最大值) '使用这个命令前 你得 置随机数种子() 图片框[A].可视=真

通用对话框还应该加入过滤,只选择图像文件

网站首页 | 网站地图
All rights reserved Powered by www.tzkr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com